Prerequisites for Installing Cisco Unity Express Software

This chapter describes the prerequisites for installing the Cisco Unity Express software on your system and contains the following sections:

Caution Caution:  Cisco Unity Express 3.1 does not support versions of Cisco Unified Communications Manager earlier than 4.1. If you are using an earlier version of Cisco Unified Communications Manager, you must upgrade to version 4.1 or a higher version to interoperate with Cisco Unity Express 3.1.

Prerequisites for Cisco Unified Communications Manager Express

Note Note:  This section is for a new installation of Cisco Unity Express 3.1.

If you are using Cisco Unified Communications Manager Express (Cisco Unified CME) licenses on your Cisco Unity Express system, then Cisco Unified CME must be installed before the Cisco Unity Express configuration can be started. If you did not or are not performing the Cisco Unified CME installation, contact the designated installer to ensure that the following procedures are completed:

Step 1   Install all Cisco Unified CME and Cisco Unity Express hardware and verify functionality.

  1. Attach the telephones so that they register with the Cisco Unified CME router. Configure the telephones and subscribers and save them to the Cisco Unified CME database. The Cisco Unity Express initialization wizard allows you to copy this data to the Cisco Unity Express database. You can create additional subscribers and telephones later using the Cisco Unity Express CLI commands or GUI options.

Use the following sample ephone-dn and ephone configurations to configure the telephones and subscribers manually:

ephone-dn 1 <---- ephone dn configuration for a user

number 8004

name User1

call-forward busy 6900

call-forward noan 6900 timeout 10

!

!

ephone-dn 20 <---- ephone dn configuration for a group

number 8801

name Salesgroup

call-forward busy 6900

call-forward noan 6900 timeout 10


ephone 1 <--- ephone configured for the ephone-dn configured above

username "Salesgroup" password null

mac-address 0009.B7F7.556A

button 1:1 2:20 3:21 4:22 5:23

  1. Verify that the Cisco Unity Express router is configured with a Cisco IOS release that supports the Cisco Unity Express network module (NM-CUE), extended capacity network module (NM-CUE-EC), enhanced network module (NME-CUE), or advanced integration module (AIM-CUE). For information on the minimum Cisco IOS release required to support these modules, see the Release Notes for Cisco Unity Express 3.1.
  2. Install the Cisco Unity Express NM-CUE, NM-CUE-EC, NME-CUE, or AIM-CUE module in the same router where Cisco Unified CME is installed.
  3. For the NM-CUE, NM-CUE-EC, and NME-CUE modules, verify that the Enable LED is lit.
Note Note:  See the "Uninterruptible Power Supply Recommendations" section.

Step 2   Install and verify Cisco Unified CME software functionality.

  1. Verify that you have web connectivity to the Cisco Unified CME configuration webpage at http://cisco-unified-cme-router-ipaddress/ccme.html.
  2. Verify that the Cisco Unified CME router flash memory has the following files, which control the functionality of the Cisco Unity Express GUI:
    • - CiscoLogo.gif
    • - Delete.gif
    • - Plus.gif
    • - Tab.gif
    • - admin_user.html
    • - admin_user.js
    • - dom.js
    • - downarrow.gif
    • - ephone_admin.html
    • - logohome.gif
    • - normal_user.html
    • - normal_user.js
    • - sxiconad.gif
    • - telephony_service.html
    • - uparrow.gif
    • - xml-test.html
    • - xml.template
  3. Configure the following path in Cisco Unified CME configuration mode:
Router(config)# ip http path flash:
  1. Verify the path with the show running-config command.
  2. Configure IP connectivity between the router and the Cisco Unity Express module. The module has an internal IP address and a default gateway configuration. The router has a service-engine interface with an IP address, which may be unnumbered.

Using the ip unnumbered command for configuration allows the Cisco Unity Express module to use a network subnet IP address associated with a specific router egress port such as FastEthernet0/0. This method requires a static route to the service-engine interface. The router interface associated with the Cisco Unity Express interface must be in an "up" state at all times for communication between the router and module.

Copy the IP address of the Cisco Unity Express module because you need it to access the GUI to configure the system. In the following example, 10.3.6.128 is the IP address of the Cisco Unity Express module and Service-Engine1/0 is the router slot hosting the Cisco Unity Express module.

interface FastEthernet0/0

ip address 10.3.6.1 255.255.255.0

.

.

.

interface Integrated-Service-Engine1/0

 ip unnumbered FastEthernet0/0

 service-module ip address 10.3.6.128 255.255.255.0

service-module ip default-gateway 10.3.6.1

.

.

.

ip route 10.3.6.128 255.255.255.255 Service-Engine1/0

If your network uses a VLAN interface with an EtherSwitch module, use the example above and replace both instances of "FastEthernet0/0" with "VLAN1."

  1. Verify that a SIP dial peer is configured to point to the Cisco Unity Express module, that it specifies G.711 u-law and SIP Notify for DTMF Relay, and that VAD is turned off. This step is required to have an incoming call directed to Cisco Unity Express 3.1. For example:

dial-peer voice 6000 voip <------ SIP dial peer pointing to Cisco Unity Express

destination-pattern 6...

session protocol sipv2

 dtmf-relay sip-notify

session target ipv4:10.3.6.128 <---- Cisco Unity Express IP address

codec g711ulaw

no vad

  1. Configure the appropriate number of SIP dial peers to support your dial plan.
  2. Verify that a Cisco Unified CME web administrator is configured with a user name and password, for example:

telephony-service

.

.

.

 web admin system name admin password user1

or

web admin system name admin secret 5 encrypted-password

Note Note:  If you plan to use the Cisco Unity Express graphical user interface (GUI) for configuration purposes, configure an administrator username with a password in the Cisco Unified CME interface. You must log in to the GUI as this user. If no administrator user is created in Cisco Unified CME, the administrator cannot proceed with the initialization wizard in the Cisco Unity Express GUI.

Step 3   The FTP server that communicates with Cisco Unity Express must support passive FTP requests. To configure this functionality on the FTP server, see the FTP server documentation.

Step 4   (Optional) If no subscribers were created in the Cisco Unified CME interface, create a list of all subscribers, groups, and their extensions to simplify the task of configuring many subscribers and extensions.

Note Note:  Designate a primary extension for each subscriber who will receive voice-mail messages. Cisco Unity Express does not activate the MWI for an E.164 number.

Prerequisites for Cisco Unified Communications Manager

If you are using Cisco Unified Communications Manager licenses on your Cisco Unity Express system, then Cisco Unified Communications Manager must be installed before the Cisco Unity Express configuration can be started.

Caution Caution:  Cisco Unity Express 3.1 does not support versions of Cisco Unified Communications Manager earlier than 4.1. If you are using an earlier version of Cisco Unified Communications Manager, you must upgrade to version 4.1 or a higher version to interoperate with Cisco Unity Express 3.1.

If you did not or are not performing the Cisco Unified Communications Manager installation, contact the designated installer to ensure that the following procedures are completed:

Step 1  (Required) Install all Cisco Unified Communications Manager and Cisco Unity Express hardware and verify functionality.
  1. Attach the telephones so that they register with the Cisco Unified Communications Manager server.
  2. Verify that the Cisco Unified Communications Manager server is configured with a Cisco IOS release that supports the Cisco Unity Express network module (NM-CUE), extended capacity network module (NM-CUE-EC), enhanced network module (NME-CUE), or advanced integration module (AIM-CUE). For information on the minimum Cisco IOS release required to support these modules, see the Release Notes for Cisco Unity Express 3.1.
  3. For the NM-CUE, NM-CUE-EC, or NME-CUE modules, verify that the Enable LED is lit.
Note Note:  See the "Uninterruptible Power Supply Recommendations" section.

Step 2   (Required) Install and verify Cisco Unified Communications Manager software functionality.

  1. You should be able to access the Cisco Unified Communications Manager configuration webpage.
  2. Configure IP connectivity between the router and the Cisco Unity Express module. The module has an internal IP address and a default gateway configuration. The router has a service-engine interface with an IP address, which may be unnumbered.

Use the ip unnumbered command to allow the Cisco Unity Express module to use a network subnet IP address associated with a specific router egress port, such as FastEthernet0/0. This method requires a static route to the service-engine interface. The router interface associated with the Cisco Unity Express interface must be in an "up" state at all times for communication between the router and module.

Copy the IP address of the Cisco Unity Express module because you need it to access the GUI to configure the system. In the following example, 10.3.6.128 is the IP address of the Cisco Unity Express module and Service-Engine1/0 is the router slot hosting the Cisco Unity Express module.

interface FastEthernet0/0

ip address 10.3.6.1 255.255.255.0

.

.

.

interface Service-Engine1/0

ip unnumbered FastEthernet0/0

service-module ip address 10.3.6.128 255.255.255.0

service-module ip default-gateway 10.3.6.1

.

.

.

ip route 10.3.6.128 255.255.255.255 Service-Engine1/0

If your network uses a VLAN interface with an EtherSwitch module, use the example above and replace both instances of "FastEthernet0/0" with "VLAN1."

  1. On the Cisco Unified Communications Manager, configure 16 CTI ports for a Cisco Unity Express system with an NM-CUE-EC module, 8 ports for an NM-CUE module, or 24 ports for an NME-CUE module. For the AIM-CUE, configure 6 CTI ports on Cisco Unified Communications Manager. Use the Cisco Unified Communications Manager option Device > Phones > Add new Phone. These ports will be used by the Cisco Unity Express applications (voice mail, autoattendant, and Administration via Telephone [AvT]) to terminate calls.
Note Note:  Do not configure extra CTI ports on Cisco Unified Communications Manager. Doing so will impact the scalability of your Cisco Unified Communications Manager and will limit the number of other devices it can support.
  1. Configure at least two Cisco Unified Communications Manager route points on Cisco Unified Communications Manager using the Device > CTI Route Point option. The Cisco Unity Express voice-mail application uses one route point, and the autoattendant application uses one route point. If you plan to use the Cisco Unity Express AvT, configure a third route point on Cisco Unified Communications Manager. You need as many route points as the number of call-in numbers on Cisco Unity Express.
Note Note:  Do not configure extra route points on Cisco Unified Communications Manager. Doing so will impact the scalability of your Cisco Unified Communications Manager and will limit the number of other devices that Cisco Unified Communications Manager can support.

 

  1. Create a Cisco Unified Communications Manager Communications Manager JTAPI user with the User > Add new user option. Use the Device Association option to associate the CTI ports and route points with this JTAPI user. (The JTAPI user is not assigned a Cisco Unity Express voice mailbox. It is a placeholder for Cisco Unity Express to establish a connection with Cisco Unified Communications Manager.) Verify that the Enable CTI Application Use check box is checked for this JTAPI user.
  2. If you are using Cisco Unified Communications Manager 5.0 or a later version, verify that the AXL service is active. To do this, go to the Cisco Unified Communications Manager serviceability website, click Tools > Service Activation. Look for Cisco AXL Web service.
  3. For efficient call processing, configure access lists on the Cisco Unity Express router to prioritize JTAPI traffic. For example:

class-map match-all jtapi

match access-group 110

class-map match-all voice

match access-group 100

policy-map jtapi

class jtapi

class jtapi

class jtapi

set dscp

bandwidth 20

class voice

set dscp af31

priority 320

class class-default

fair-queue

interface Serial0/1

ip address 192.168.10.0 255.255.255.0

service-policy output jtapi

clockrate 256000

no cdp enable

access-list 100 permit udp host 10.3.6.128 any range 16383 32727

access-list 110 permit tcp host 10.3.6.128 any eq 2748

where 10.3.6.128 is the IP address of the module that contains Cisco Unity Express.

The output from the show policy-map interface command should indicate that the marked packets number is increasing. For example:

Match: access-group 110

QoS Set

dscp cs3

Packets marked 334   <-----This number should increase.

Step 3   (Required) The FTP server that communicates with Cisco Unity Express must support passive FTP requests. To configure this functionality on the FTP server, see the FTP server documentation.

Step 4  (Optional) If no subscribers were created in the Cisco Unified Communications Manager interface, create a list of all subscribers, groups, and their extensions to simplify the task of configuring many subscribers and extensions.

 All contents are Copyright 1992–2009 Cisco Systems, Inc. All rights reserved.