WIC-1DSU-T1 and WIC-1DSU-T1-V2 DSU/CSU Wan Interface Card (WIC)

In this section you will identify the following aspects of the WIC-1DSU-T1 and WIC-1DSU-T1-V2:


Overview and LEDs of the WIC-1DSU-T1 and WIC-1DSU-T1-V2:

The 1-port T1/fractionalized T1 (FT1) DSU/CSU WIC includes an integrated data service unit/channel service unit (DSU/CSU). The WIC can be configured for either full T1 services or fractionalized T1 services. T1 CSU/DSU WIC does not do channelized T1 or ISDN Primary Rate Interface (PRI). There are two T1/FT1 DSU/CSU WICs: (see fig2-1) The WIC-1DSU-T1-V2 (version 2) interface card supports wetting current. Wetting current is a small amount of electrical current (60 to 140 milliamps) sent from the central office to the card to prevent the corrosion of electrical contacts in the card's network connection.

Figure 2-1: WIC-1DSU-T1 and WIC-1DSU-T1-V2 Front panel
Secure Services Layer Module

Table 2-1: WIC-1DSU-T1 and WIC-1DSU-T1-V2 LEDs
Secure Services Layer Module

Figure 2-2: Connecting the WIC-1DSU-T1 and WIC-1DSU-T1-V2 to a T1 Wall Jack
Secure Services Layer Module

Basic Configuration of the WIC-1DSU-T1:

This section provides a configuration example for a Cisco 1751 router with a WIC-1DSU-T1-V2 card installed. It is in a short cable environment (between 330 and 440 feet here), and is set to enter loopback when a loopback code is received on the line.

Current configuration :
!
version 12.2
no parser cache
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1751-uut1
!
interface Serial0/0
ip address 10.0.0.51 255.0.0.0
service-module t1 framing esf
service-module t1 linecode b8zs
service-module t1 timeslots 1-12 speed 64
service-module t1 data-coding normal
service-module t1 cablelength short 440ft
service-module t1 remote-loopback full
!
interface FastEthernet0/0
ip address 6.0.0.1 255.0.0.0
speed auto
full-duplex
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Show Service-Module command of the WIC-1DSU-T1 and WIC-1DSU-T1-V2:

Router#show service-module serial0/0 
Module type is T1/fractional 
             Hardware revision is 0.1, Software revision is 20021210, 
             Image checksum is 0x81277248, Protocol revision is 0.1 
           Receiver has no alarms. 
           Unit is currently in test mode: 
             remote loopback is in progress 
           Framing is SF, Line Code is AMI, Current clock source is line, 
           Fraction has 24 timeslots (56 Kbits/sec each), Net bandwidth is 1344 Kbits/sec. 
           Last module self-test (done at startup): Passed 
           Last clearing of alarm counters 01:52:27 
             loss of signal        :    1, last occurred 01:45:24 
             loss of frame         :    2, last occurred 01:45:24 
             AIS alarm             :    0, 
             Remote alarm          :    0, 
             Module access errors  :    0, 
           Total Data (last 7 15 minute intervals): 
             255 Line Code Violations, 0 Path Code Violations 
             1 Slip Secs, 326 Fr Loss Secs, 6 Line Err Secs, 0 Degraded Mins 
             2 Errored Secs, 0 Bursty Err Secs, 7 Severely Err Secs, 327 Unavail Secs 
           Data in current interval (445 seconds elapsed): 
             0 Line Code Violations, 0 Path Code Violations 
             0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins 
             0 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 0 Unavail Secs 

Configuration Commands:

interface serial 0/0
service-module t1 timeslots all (configures which timeslots (DS-0s) are used in fractional T1 operation. Default: all)
service-module t1 clock source line (accept the source of clock from the line. Default: clock source line)
service-module t1 clock source internal (generate clocking internally, needed if put 2 units back to back. Default:clock source line)
service-module t1 framing {sf | esf} (for operation with D4 Super Frame (sf) or Extended Super Frame (esf). Default: esf)
service-module t1 linecode {b8zs | ami} (for operation on Binary 8 Zeroes Substitution (B8ZS) or Alternate Mark Inversion (AMI) T1 lines. Default: b8zs)
service-module t1 remote-loopback [full | payload] [v54 | alternate] (The service-module t1 remote-loopback command specifies whether the T1 CSU/DSU goes into loopback when it receives a loopback code on the line. The [full | payload] parameter specifies whether the T1 CSU/DSU accepts full loopbacks (CSU loopback) or payload loopbacks (DSU loopback). To disable remote loopbacks, use no service-module t1 remote-loopback. The T1 module will not generate loopback codes via the loopback remote command if configured for no service-module t1 remote-loopback.

Exec commands:

clear service-module serial 0/0 (hardware reset of the CSU/DSU module)
clear counters
test service-module serial 0/0 (CSU/DSU self-test of flash, eeprom, ROM, RAM, DTE loopback test pattern. See show service-module)

Hardware Based Loopback (using loopback plug):

Change the serial interface to HDLC encapsulation as below, connect the loopback plug to the serial interface and ping (extended) from the router CLI to the serial interface's IP address.

interface Serial 0/0
encapsulation hdlc
ip address 10.0.0.51 255.0.0.0

Software Based Loopback Commands (no loopback plug used):

Figure 2-3: T1 CSU/DSU module placed into DTE loopback
Secure Services Layer Module

 

interface serial 0/0
loopback dte

Traffic generated by the DTE (PING, for example) is looped back to the DTE.

Figure 2-4: T1 CSU/DSU module placed into loopback line
Secure Services Layer Module

 

interface serial 0/0
loopback line

The CSU/DSU module loops the line through the CSU portion of the module and loops the DTE interface back to the router.

Figure 2-5: T1 CSU/DSU module placed into loopback line payload
Secure Services Layer Module

 

interface serial 0/0
loopback line payload

The CSU/DSU module loops the line through the DSU portion of the module.

Figure 2-6: T1 CSU/DSU module placed into loopback remote full
Secure Services Layer Module

 

interface serial 0/0
loopback remote full

Sends the loop up code to the remote CSU/DSU. The remote CSU/DSU goes into the equivalent of a loopback line, which is a full bandwidth loopback through the CSU portion of the module.

Figure 2-7: T1 CSU/DSU module placed into loopback remote payload
Secure Services Layer Module

 

interface serial 0/0
loopback remote payload

Sends the loop up code to the remote CSU/DSU which puts the remote CSU/DSU into the equivalent of a loopback line payload. The remote CSU/DSU loops back only those timeslots on which it received the loop up code.

Figure 2-8: T1 CSU/DSU module placed into loopback remote smart-jack
Secure Services Layer Module

interface serial 0/0
loopback remote smart-jack

sends a loop up code to the remote smart jack. You cannot put the local smart jack into loopback. The smart-jack loopback does not apply to the WIC-1DSU-T1.


 All contents are Copyright 1992–2009 Cisco Systems, Inc. All rights reserved.